MagiCal Bug Report

42 Votes

Calendar shown, but no reaction to clicks under 10.6

  • Type: Incorrect Functionality
  • Version Tested: 1.1r1 (Intel)
  • OS Version Affected: Mac OS X 10.6 (Snow Leopard)
  • Status: Fixed in version 1.1r2

Description

Hi,

running MagiCal under 10.6 seems to be possible and, when clicking on the menubar item, the calendar pops out, but clicking on the "i" or trying to toggle months doesn't seem to work.

Kind regards,
Ralf.

Submitted by Ralf Holighaus at 10:50am on 26 Aug 2009

Resolution

The Snow Leopard compatible version is now available for download: http://www.charcoaldesign.co.uk/magical

Updates

Hi,

Magical 'just leaking' under Snow Leopard says the Console. When is a Snow Leopard compatible verison due?

Thanks!

- -
Kind regards,
Marc Vos

Posted by Marc Vos at 3:26pm on 01 Sep 2009

In addition to that, I'm unable to click on the "i" or anywhere in the calendar (unable to switch months) for that matter. Please release a compatible version. Thanks!

Posted by Wysie at 06:09am on 03 Sep 2009

Sorry I forgot to add, sometimes clicking on MagiCal in the Menubar does not cause anything to happen (calendar does not appear).

Posted by Wysie at 06:10am on 03 Sep 2009

Same issue here :(.

Posted by Wysie at 06:11am on 03 Sep 2009

Same issue here. Is there any other way to get at the preferences?

Posted by Scott Palmer at 6:24pm on 04 Sep 2009

Answered my own question. Using the Command-, key combination you can access the preferences window. Unfortunately, the same issue occurs with the preferences window as with the calendar drop down, none of the controls are clickable, and I can only tab through a couple of fields.

Posted by Scott Palmer at 2:18pm on 09 Sep 2009

Yah, same here. I love this little app. Hope there's a fix soon.

Posted by Eddie at 4:26pm on 14 Sep 2009

Confirmed this application version is DEAD and USELESS under Snow Leopard; please release an updated version that restores functionality

Posted by Norm Gilbert at 4:12pm on 16 Sep 2009

Yes, same issue here. Please fix. I love magical!

Posted at 03:52am on 18 Sep 2009

Same issue as others report. Handy app and I like it a lot. Hope you can update.

Posted by John at 3:06pm on 18 Sep 2009

Same problem here. Magical is one of my absolute favorite apps in OSX, so I really hope this is fixed ASAP!

Posted by Matthew Brown at 12:35am on 19 Sep 2009

Looking forward to an update, keep up the awesome work.

Posted by Chris Gabriel - Trampish Designs at 12:42pm on 22 Sep 2009

A fix has been developed and will be released shortly.

Posted by Nick at 11:51pm on 23 Sep 2009

Yay! Thanks for that quick fix. Time to buy you a beer! (Or whatever you want to do with the $$)

Posted by Scott Palmer at 02:05am on 26 Sep 2009

I, too, am still having the Snow Leopard bug wherein the calendar doesn\'t respond at all when clicking the \"i\" or anything else.

And this despite downloading the very latest version.

:(

It doesn\'t seem to be so fixed as its bug status seems to indicate

Posted at 02:12am on 04 Jan 2010

You may have downloaded the new version but still somehow be running the old one.

Try the following:

1) Open the Activity Monitor application (you'll find it in Applications/Utilities)
2) Use Activity Monitor to Quit any running instances of MagiCal
3) Move all copies of MagiCal to the trash and empty
4) Download the latest version from the site and drag it into Applications
5) Launch MagiCal

Posted by Nick at 10:23pm on 04 Jan 2010

I just did a new (fresh, not upgrade) install of Snow Leopard. With updates it\'s at 10.6.2, and I get the same \"non-responsive\" behavior that was supposedly fixed in the version I have (1.1r2). There was no other version, and I have tried everything (blowing away plist, getting a new download, etc.).

Can someone verify responsiveness under 10.6.2?

Posted at 9:38pm on 07 Jan 2010

I'm using 10.6.2 and it 1.1r2 works fine for me. I still think the most likely explanation is that you've installed 1.1r2 but somehow 1.1r1 is what's running, possibly because it was left behind in your list of login items after you upgraded.

Try quitting MagiCal, going to System Preferences/Accounts/Login Items and removing any copies of MagiCal from the list and then double-clicking the MagiCal 1.1r2 icon again.

Also which version of MagiCal are you using - is it the Intel build or the universal binary? It's possible there may be an issue with one and not the other, although I've not had any reports.

Posted by Nick at 10:52pm on 08 Jan 2010

Thanks for the reply. Still no luck. Again, this is a new system so pre 1.1r2 was not on this system at all. I've tried the Intel and Universal versions, deleting, emptying trash, and rebooting each time. Next week I'll try it on some other Snow Leopard systems at work to see if I can reproduce the problem. I have added a few plug-ins, preference panes, etc., on this new system, but nothing I didn't have on my old Leopard 10.5.x install when magical worked.

Posted by achecht at 12:13am on 09 Jan 2010

Tried it (Intel 1.1r2) on another 10.6.2 system, and it does work there. I can't for the life of me figure out what's causing the problem on my MacBook Pro (the model just before the unibody). I tried all of the above advice with both the intel and universal versions.

I did notice that usually, I don't even get the "i" icon in the lower right of the calendar in 1.1r2. But once today I did -- it was still unresponsive, but it was there. I even tried running my system bare -- without other plugins and menu apps.

Posted by achecht at 2:08pm on 11 Jan 2010

I was *finally* able to resolve this issue today after not hearing any more suggestions from Charcoal (no judgement in that statement...I didn't have any suggestions either).

But then today I decided to launch Snow Leopard into Safe Boot (by holding down the shift key while the computer is booting up after having been powered off). I ran Magical (intel 1.1r2) and was able to get it to work properly. While in safe boot, I went into Magical preferences and set some custom prefs up (so that the app would generate the plist file under ~/Library/Preferences). I then also quit the app, put it in the trash, and then emptied the trash. I wanted to make sure I was getting rid of every instance of the app under safe boot.

Still in safe boot, I then unzipped Magical from the same download file, put it in my Apps folder, and ran it again. Everything still worked fine, and my new Magical prefs were still intact.

I then rebooted the computer into standard boot (not the safe boot), and Voila! Magical was still responsive even under a normal boot.

I'm not sure what the problem was with my system, but I wanted to post my solution in case anyone else had the same experience.

Posted by achecht at 4:18pm on 13 Jan 2010

@achecht

This is great! I was having the same problem and had given up on ever using MagiCal again under Leopard. But your solution worked perfectly. Thanks for sharing!

~J

Posted by john at 8:49pm on 15 Jan 2010

Add More Information

(optional)

(optional, will not appear on report)

What is nineteen minus seven?
(MAPTCHA)