Shades Bug Report

2 Votes

PrefPane refuses to load under MacOS 10.5.8

  • Type: Incorrect Functionality
  • Version Tested: 1.2b3 (Universal)
  • OS Version Affected: Mac OS X 10.5 Intel
  • Status: Fixed in version 1.2b3

Description

The just-released 1.2b3 Shades refuses to load on my intel iMac. This message is printed to the console:
9/25/09 7:11:54 PM System Preferences[3884] [NSPrefPaneBundle instantiatePrefPaneObject] (/Library/PreferencePanes/Shades Preferences.prefPane): principalClass is nil.

1.2b2 was working fine until the upgrade attempt. I tried removing the plist file and doing a clean install of the PrefPane but it didn't help.

Submitted by Andrew at 12:18am on 26 Sep 2009

Resolution

Yep, sorry, my bad. I accidentally built the PrefPane for 10.6 only. I've rebuilt and re-uploaded so if you download it again it should work okay now.

Updates

Attempted to upgrade to 1.2. Shades would not perform upgrade and only displays this message:

Preferences Error

Could not load Shades Preferences preference pane.

Posted by John at 12:53am on 26 Sep 2009

Now fixed.

Posted by Nick at 02:00am on 26 Sep 2009

Add More Information

(optional)

(optional, will not appear on report)

What is twenty-two plus ten?
(MAPTCHA)