MagiCal Bug Report

4 Votes

Calendar disappeared

  • Type: Incorrect Functionality
  • Version Tested: 1.1a2 (Universal)
  • OS Version Affected: Mac OS X 10.4 Intel
  • Status: Fixed in version 1.1

Description

These aren't complaints, but bug reports. MagiCal is Alphaware and I know it has bugs.

I opened and tore away a few calendars, then closed them. After doing this half a dozen or so times, when I clicked the calendar icon, the calendar didn't appear. I had to use Option Commnand to drag the icon out of the menu. This happily opened MagiCal's options, so I clicked the Show Icon to restore it to the Menu bar, after which the calendar reappeared.

Also, the Next and Previous month arrows seemed a bit shaky. After clicking a couple of months ahead, the previous month arrow did not seem to want to work. The calendar would disappear when I clicked the Previous month arrow. When I tore the display off, the Previous Month arrow would then work.

I hope these comments are helpful.

Submitted by Gene van Troyer at 03:17am on 21 Apr 2007

Resolution

This bug was fixed in 1.1, and the crashing issue on 1.1 under Leopard has now been fixed in 1.1r1, so there should be no need to use this version any more.

Updates

Very helpful, thank you.

I'm investigating these issues now. In the meantime I suggest selecting the "use legacy calendar" option, which uses the MagiCal 1.0.9r4 calendar.

Posted by Nick at 07:24am on 21 Apr 2007

The calendar does not disappear but simply displays too high : the calendar's shadow can be seen right under the menubar.

Posted by Patrick Moisan at 2:53pm on 23 Apr 2007

Neither cal nor time menu drops down, just a shadow below the menubar.

Worked fine yesterday.

Thank you,
Todd

Posted at 6:41pm on 03 May 2007

This seems to be an intermittent fault. I can reproduce it, but I can't figure out what triggers it - it seems to be random.

If it's happening for you regularly, I suggest switching to using the legacy calendar (look in preferences/calendar), or delete your preferences file if this issue is stopping you from accessing the preferences within MagiCal.

Posted by Nick at 10:35pm on 03 May 2007

Resolved with 1.1a7 install

Posted at 10:56pm on 03 May 2007

Still occurs for me with 1.1a8. Back to the legacy calendar for me.

Posted by Kevin Yank at 2:29pm on 04 May 2007

Happens to me too

Posted at 8:40pm on 18 Dec 2007

Add More Information

(optional)

(optional, will not appear on report)

What is twenty-two plus ten?
(MAPTCHA)