Shades Bug Report

49 Votes

Slider broken on Snow Leopard

  • Type: Incorrect Functionality
  • Version Tested: 1.2b2 (Intel)
  • OS Version Affected: Mac OS X 10.6 (Snow Leopard)
  • Status: Fixed in version 1.2b3

Description

Hi folks,

Shades is not working under Snow Leopard (latest Beta after WWDC)!

You can not move the buttons!!

Greetings

Frank

Submitted by Frank at 10:28pm on 16 Jun 2009

Resolution

The Snow Leopard compatible version is now available for download: http://www.charcoaldesign.co.uk/shades

Updates

Sliider control works fine!

Posted by Snow Leopard 10.6 at 02:06am on 29 Aug 2009

I was updating Leopard to Snow Leopard. After that Shades does not work!
Slider above of screen can not run.
We hope it is fixed A.S.A.P.
Thank you.

Posted by Yasuhiro Miyake at 10:33am on 29 Aug 2009

under my 10.6 up-date - shades works, keyboard + and - brightness work, menu control appears but does nothing

Posted by keith at 10:49am on 29 Aug 2009

After Snow Leopard Installed, I\'m seeing the following logged to console fairly
frequently:

*** attempt to pop an unknown autorelease pool

Same problem ?
http://www.mail-archive.com/growldiscuss@googlegroups.com/msg01186.html

Posted by waverider at 12:49pm on 29 Aug 2009

same as reported by keith above
menu bar control appears when clicked on but i am unable to move slider to adjust brightness
using snow leopard 10.6

Posted by Ziggar at 4:53pm on 29 Aug 2009

as above report
unable to use menu bar slider after installation of OS X 10.6 snow leopard

Posted by Ziggar at 4:55pm on 29 Aug 2009

menu bar slider appears when you click on it but you are unable to adjust brightness with it at all

everything else seems to work OK

Posted by Ziggar at 4:59pm on 29 Aug 2009

I upgraded to Snow Leopard on my Mar '09 24" iMac and the brightness slider doesn't appear when I click on the Shades icon in the menu bar. Alt - and Alt + still work fine.

Posted by kfscoll at 5:03pm on 29 Aug 2009

forgot to say that you CAN adjust the slider using the scroll wheel on a logitech mx8 mouse

Posted by Ziggar at 5:59pm on 29 Aug 2009

Ditto - the Slider works with the Mouse Scroll Button on the Apple Mouse. Thanks for the tip!!!

AK

Posted by pboc at 3:36pm on 31 Aug 2009

I agree - the button won't move.

Posted by Bernie at 3:44pm on 03 Sep 2009

cant start the program anymore after upgrading to lepper

Posted by Kevin Kissack at 1:04pm on 04 Sep 2009

Thank you again for this great helper. Millions of eyes in the world thank you ;-)

Posted by Boumy at 7:48pm on 04 Sep 2009

Snow Leopard - Button stuck.

Posted by q at 1:59pm on 05 Sep 2009

Yes, same problem here after installing the release edition of Snow Leopard - not fixed by removing/reinstalling Shades.

Posted by Tom at 10:56pm on 05 Sep 2009

addendum to previous bug report - the menubar object is what has the problem. The hovering control bar works fine.

Posted by Tom at 11:02pm on 05 Sep 2009

How does the hovering control bar work?

Thanks.

Posted by Paul at 1:11pm on 06 Sep 2009

slows SL extremly down.
console full of error msgs.

06.09.09 18:27:23MagiCal[167]*** __NSAutoreleaseNoPool(): Object 0x2a0eef30 of class NSImage autoreleased with no pool in place - just leaking
06.09.09 18:27:23MagiCal[167]*** __NSAutoreleaseNoPool(): Object 0x2a0f0120 of class NSBitmapImageRep autoreleased with no pool in place - just leaking
06.09.09 18:27:23MagiCal[167]*** __NSAutoreleaseNoPool(): Object 0x2a5734e0 of class NSImage autoreleased with no pool in place - just leaking
06.09.09 18:27:23MagiCal[167]*** __NSAutoreleaseNoPool(): Object 0x2a5734e0 of class NSImage autoreleased with no pool in place - just leaking
06.09.09 18:27:24com.apple.launchd.peruser.501[125]([0x0-0x12012].com.charcoaldesign.magical[167]) Exited: Killed

Posted by david at 6:02pm on 06 Sep 2009

Button works if you move pointer over the slider and than use the ball of the mouse
I do agree that it should be fixed but its a workaround

Posted at 01:32am on 09 Sep 2009

Please keep updating this app! Excellent work, but we need Snow Leopard support!

Posted by Aaron at 04:24am on 09 Sep 2009

I love this app...but we need SL support ASAP! I'd gladly donate even more if it'd speed up SL upgrade development!

Posted by kfscoll at 02:44am on 11 Sep 2009

Good tip...slider also works when using the scroll wheel a Rocketfish Bluetooth Laser Mouse for Mac.

Posted by kfscoll at 02:50am on 11 Sep 2009

Hello, I just installed Shades, and the installation went ok but the brightness pop-down button up in the menu bar is frozen in place and will not move. I have tried several re-installs to no avail. Further, I can't figure out how to remove the thing from my hard-drive. Help! PJB/

Posted at 07:05am on 12 Sep 2009

Happened as soon as I installed Snow Leopard. Sliders are frozen but previously chosen dimming values are active.

Posted by mike at 07:46am on 12 Sep 2009

Yep here too.. frozen bar.. after installing 10.6 and updating too 10.6.1

Posted at 08:50am on 14 Sep 2009

v 1.2b2

Snow Leopard

Slider does not work.

Posted by Jason at 4:56pm on 14 Sep 2009

Please fix this bug soon. I love Shades but it's now not functioning as well as it should without slider adjustment.

Posted at 1:42pm on 15 Sep 2009

Shadesloads under Snow leopard but the slider can not be moved, so Shades is not functional...

Posted at 07:46am on 17 Sep 2009

Same here

Posted by DA at 10:07pm on 17 Sep 2009

The desktop form of the slider still works though.

Posted by Shane at 03:42am on 18 Sep 2009

Sorry in my last I should've been clearer - the menu bar slider doesn't work but the desktop slider does. It's a work-around, if you don't mind work-arounds....

Posted by Shane at 03:43am on 18 Sep 2009

Menu bar slider doesn't work but desktop slider does.

Posted by Shane at 03:45am on 18 Sep 2009

Same here : cursors in menu bar frozen under Snow Leopard, and cursor on screen works.

Posted by Stampes at 1:49pm on 19 Sep 2009

doesn't work properly after 10.6

Posted at 01:29am on 22 Sep 2009

menu bar don't work - frozen.

Posted at 01:39am on 22 Sep 2009

A fix has been developed and will be released shortly.

Posted by Nick at 11:41pm on 23 Sep 2009

You can adjust the brightness with the desktop "floating" object just fine - that has always worked, just no-go on the dropdown control from the menubar.

Posted by Tom at 05:46am on 24 Sep 2009

I bought DarkAdapted and it works fine

Posted by kevin at 10:06am on 24 Sep 2009

frozen slider, when is next version available? Thanx

Posted by bill at 12:38am on 25 Sep 2009

i've been using shades for 3 weeks on a brand new computer and today this bug (or another with the same behavior) re-appeared on me

Posted at 04:44am on 11 Apr 2010

The slider works for me with 10.6.4 but I have to hit the menubar icon precisely in the center for it to pull down. Shades 1.2b3.

Posted at 01:00am on 01 Jul 2010

I am unable to move slider to adjust brightness, I'm using snow leopard 10.6.4

Posted by Niclas at 11:47pm on 21 Jul 2010

Try shutting down Shades, then deleting your Shades preferences (user/library/preferences/com.charcoaldesign.shades.plist). It may be that they have become corrupted.

Posted by Nick at 11:52pm on 21 Jul 2010

*** I just found out why the slider is not working ***
Problem: When you click on the shades icon, the slider does not always appear.
I think the reason is so simple - the 'hot-spot' area for the cursor to click on is is too small (or wrongly positioned).
Make it bigger and the problem will go away.
Cheers,
Paul.

Posted by Paul at 8:48pm on 07 Aug 2010

Add More Information

(optional)

(optional, will not appear on report)

What is twenty-two plus ten?
(MAPTCHA)